Originally posted by: Myran
Originally posted by: Cal_kashi
Score(assertionfailure, point++);
That makes no sense at all.

Its logical that a func like that would have its 2nd parameter simple do an offset on the score (Score(assertionfailure, 1);), even if that was not the case, it would seem logical that the func would take sth like Score(assertionfailure, assertionfailure.points++); otherwise the point is just a general var, and the point is obviously to increase assertions points with one, so why use another generic var?
Clearly it is for simplicity/orginization, assertnfailure is a name which is assigned to more than one thing but if he only wanted to incriment his points not anything else. The syntax may be a little messed up but the idea is the same!

So
assertnfailure_points = assertnfailure_points + 1;
or maybe
assertnfailure_points ++;
there you have it.